Script Mikrotik Pengganti Userman

Hi, Mengawali saya mulai nulis blog lagi, di sela sela waktu luang sebagai admin hotspot milik saya sendiri, kali ini saya mau berbagi script mikrotik untuk eksekusi user berdasarkan profil supaya auto matis bisa set kuota dan masa aktif serasa seperti di User Manager Mikrotik.

Mungkin banyak yang minat dari pengguna mikrotik Level 4, meskipun RB sudah support userman namun masih sebatas 20sesi. maka dari itu saya mencari cari racikan script via forum maupun Group dan mengembangkannya sesuai selera saya sendiri supaya nyaman dan mampu tampung user aktif lebih dari 20user..

Hi, Mengawali saya mulai nulis blog lagi, di sela sela waktu luang sebagai admin hotspot milik saya sendiri, kali ini saya mau berbagi script mikrotik untuk eksekusi user berdasarkan profil supaya auto matis bisa set kuota dan masa aktif serasa seperti di User Manager Mikrotik.

Mungkin banyak yang minat dari pengguna mikrotik Level 4, meskipun RB sudah support userman namun masih sebatas 20sesi. maka dari itu saya mencari cari racikan script via forum maupun Group dan mengembangkannya sesuai selera saya sendiri supaya nyaman dan mampu tampung user aktif lebih dari 20user..

oke langsung saja kita mulai dari script harian yang saya gunakan;

Script kuota 2GB, masa aktif 1 hari, experied jam 5 Pagi user automatis terhapus :

:local userStr [:tostr $user];
:local paket [/ip hotspot user get [find name=”$userStr”] profile];
{
:local date [ /system clock get date ]
:if ( [ /ip hotspot user get $user comment ] = “” ) do={
[ /ip hotspot user set $user comment=”Terjual: $paket, $date” ]
}
}
:local pengguna $user;
:local time [/system clock get time];
:log warning “$pengguna telah login pada jam $time”;
{
:if ([/ip hotspot user find name=$pengguna limit-bytes-total=2048M]=””) do={/ip hotspot user set [find name=$pengguna] limit-bytes-total=2048M};
:if ([/system scheduler find name=$pengguna]=””) do={
/system scheduler add name=$pengguna start-time=05:00:00 interval=1d on-event=”/ip hotspot user remove [find name=$pengguna]\r\n/ip hotspot active remove [find user=$pengguna]\r\n/system scheduler remove [find name=$pengguna]”
}
}

Script kuota 1GB, masa aktif 17 Jam, user ototamis terdisable ketika sudah 17Jam :

:local userStr [:tostr $user];
:local paket [/ip hotspot user get [find name=”$userStr”] profile];
{
:local date [ /system clock get date ]
:if ( [ /ip hotspot user get $user comment ] = “” ) do={
[ /ip hotspot user set $user comment=”Terjual: $paket, $date” ]
}
}
:local pengguna $user;
:local time [/system clock get time];
:log warning “$pengguna telah login pada jam $time”;
{
:if ([/ip hotspot user find name=$pengguna limit-bytes-total=1024M]=””) do={/ip hotspot user set [find name=$pengguna] limit-bytes-total=1024M};
:if ([/system scheduler find name=$pengguna]=””) do={
/system scheduler add name=$pengguna interval=17h on-event=”/ip hotspot user disable [find name=$pengguna]\r\n/ip hotspot active remove [find user=$pengguna]\r\n/system scheduler remove [find name=$pengguna]”
}
}

INFO : Script diatas System Kuota bukan System durasi (Uptime). bekerja dengan baik di mikrotik OS Versi 6.40.6 .

Cara Pengguna’an, paste script tersebut pada Menu Hotspot User Profiles.

Bila akun user yang dibuat telah laku / dilogin maka akan tertera keterangan Terjual pada kolom Komen,


Serta otomatis masa aktif user masuk dalam System Schedul.


Seperti itulah script yang saya gunakan selama ini sebagai solusi pengganti userman mikrotik.

Menurut saya lebih ringan dan gak terlalu ribet dibanding instali webmikrotik api.

Bila ingin Creat user dengan mudah via Hape tinggal custom webfig mikrotik menjadi seperti gambar dibawah ini :


Dah Sempurna banget menurut saya.

Script diatas bisa dikembangkan ke paket lain seperti 1 Minggu maupun 1 Bulan.


EmoticonEmoticon